BimmerFest BMW Forum banner

Whining noise from A/C Compressor

2797 Views 5 Replies 4 Participants Last post by  nuwaus
Hi everyone!

I have a 320d pre-facelift with M47 engine and my A/C Compressor making a strange whining noise when the clutch is engaged.

This whining noise changes its pitch with the engine RPM and when it happens I get poor cooling too.

I have changed everything except for the A/C compressor including evaporator, condenser, expansion valve, filter and cleaned all the hoses.

I read some says it happens when lack of oil/lubrication in the compressor or when low on freon, but I have topped them up too (not sure if it leaks)

Can anybody help me to troubleshoot this issue as it's a real headache now for almost a month?
1 - 6 of 6 Posts
yeah...that's about right my wife's wined and it too changed pitch, soon there after no cold air...I changed the compressor took it to the shop.. .charged with freon (1.6 lbs) and haven't heard a complaint or wine since...about the car that is,,,[emoji54]

Sent from my SM-J727T using Tapatalk
I have properly charged the system, with the proper amount of freon which is 740 grams as mentioned on the sticker on the hood.

But when the system gets pressurized, whine starts and low cool level since then, one said it can be because of the condenser bad or the expansion valve is open too much,

could this be possible?
No. A compressor whines because there’s something mechanically wrong with it.
The strange thing is, there is no whine till I run the car for like 10 mins, and soon after top-up freon, so first I suspected if it was a leak, but later found out there are no leaks, so I'm still struggling to find out the cause.
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top