BimmerFest BMW Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Getting occasional yellow and red oil level indication on dash.
Oil is fresh 0W-40 and right within dip stick marks.
Will a faulty sensor lock out the engine from starting (even though oil is up to adequate level)?

I don't want to get stranded.

2005 325 XiT, 72,000 miles.
:dunno:
 

·
Freedom isn't free!!
Joined
·
19,789 Posts
No. Just fyi - yellow indicates low oil level, red indicates low oil pressure. There are two different sensors. My oil pressure sensor used to flicker whenever my RPMs were low like when I was sitting at a stop light. Got it replaced, no more flickering.
 

·
Supporting Member
Joined
·
1,519 Posts
No, it won't keep it from starting. You might consider replacing a sensor or two.
 

·
Registered
Joined
·
3 Posts
Getting occasional yellow and red oil level indication on dash.
Oil is fresh 0W-40 and right within dip stick marks.
Will a faulty sensor lock out the engine from starting (even though oil is up to adequate level)?

I don't want to get stranded.

2005 325 XiT, 72,000 miles.
:dunno:
Yes!!! It could cause lock out car from starting!!! At least I have this case!
I have 2002 330i and my car shuts down by itself while it was idling at my back yard. It was damn suddenly. Right after that I get CEL on but couldn't read it with OBD-reader for $60 from Autozone. Camshaft Exhasut, Intake and Crankshaft sensors was replaced with OEM parts 2 days before that so I had no idea what cause car from shutting down this time.
So I towed to BMW dealer and they read tons of faults (67). Once they reset them car starts again. But the guy from dealership says that the reason why car shuts and wont start was FREAKING OIL LEVEL SENSOR!!! Computer shut car down and wouldn't let it starts because "he thinks there's no oil"!
So now I'm looking for $450 for get that job done at dealer. I can do that at home but after that I need to reset codes with professional tools (not a crap from AutoZone) so it doesn't make sence go back to dealer and pay $118 more for reseting. Let them work... I'm f***ing tired of this repairs...
 

·
Registered
Joined
·
7 Posts
my oil light used to flash about 9 times when starting car up n then goes off. i was driving the car like this for 7months. now all o9f a sudden the car has failed to start on me :( something dont allow power to go to the fuel pump. Changed relays but no joy. Now i'm thinking the same thing.. is the oil level sensor causing this problem on a 1998 e36 m3 evolution? someone please help
 

·
Registered
Joined
·
3 Posts
my oil light used to flash about 9 times when starting car up n then goes off. i was driving the car like this for 7months. now all o9f a sudden the car has failed to start on me :( something dont allow power to go to the fuel pump. Changed relays but no joy. Now i'm thinking the same thing.. is the oil level sensor causing this problem on a 1998 e36 m3 evolution? someone please help
Sorry to hear about your problem suffy

I've been thru my repair and actually I got rid of my E46 330i. I'm so happy that I sold it even though I lost over $3500 at rerpairs etc. It was a lemon. Anyways someday I'll get another e46. Probably M3:))) BUT I WOULD NEVER BUY A BMW KNOWING THAT THERE WAS 4 OWNERS!!!
Now my ride is 07 Camry, I4. Awessome vehicle. Not a BMW but I'm satisfied.

Now lets go back to the point. I wrote a post a couple month ago and said that "faulty oil level sensor will prevent car from starting". IT IS WRONG! It won't! At least from my practise! Those douches from dealership told me it would prevent though! That's how I got confused. But they were just bull**itting! They did charge me for $450 for all those 67 codes erasing and putting new oil level sensor. But my car used to keep on stalling.
Then one person suggest me to check fuel pump. Once I pulled it out I saw empty tank! Completelly! Even though my gauge showed me around 40% of tank was full. How the fu*k was I supposed to now that the level shown on dash is wrong... ?

So I ended up with FAULTY GAS LEVEL GAUGE. It's acctually was fulty sending unit (driver side! not a passenger one).

So the moral of this story is quite simple. There are millions of opinions but once You've been thru each repair by your own you know what to do next time. Even professionals from BMW dealership bull**itting sometimes. They just want your money.

P.S. BTW, the person who suggest me to check fuel pump was a mechanic that I accidentally and for my luck got chance to speak with.

GOOD LUCK WITH YOUR BMW BRO!!!!
 

·
Registered
Joined
·
7 Posts
hey thanks 4 getting bak at me. n ur damn right they bul****ted u! lol i changed the oil level sensor and still no joy. very simple to change myself. oil light stopped flashing n that was the only good thing about it. so then i thought f*@k it and decided to strip off all the panels and follow the fuel pump live wire. it went straight into my alarm unit. i disconnected it from there and connected them together. tried starting it and it fired up straight away :). so basically it was just my immobiliser which had played up and it cost me nothing but time to fix it. soo glad i didnt pass it on to main dealer, god knows what they wouldve charged me for.
Once up n running with all the plastics n wiring back in place it was time for a cruise in the sun with the roof down.... but guess what... my bloody roof stopped working now!!! grrr lol. i am now just driving it and am not looking forward to having a go to fix the roof! lol the joys of motoring eyy
yours had just run outa fuel? lol goes to show these highly paid bmw technicians are a load of bollox. we done better ourselves
 

·
Noone Special
Joined
·
673 Posts
Yes!!! It could cause lock out car from starting!!! At least I have this case!
I have 2002 330i and my car shuts down by itself while it was idling at my back yard. It was damn suddenly. Right after that I get CEL on but couldn't read it with OBD-reader for $60 from Autozone. Camshaft Exhasut, Intake and Crankshaft sensors was replaced with OEM parts 2 days before that so I had no idea what cause car from shutting down this time.
So I towed to BMW dealer and they read tons of faults (67). Once they reset them car starts again. But the guy from dealership says that the reason why car shuts and wont start was FREAKING OIL LEVEL SENSOR!!! Computer shut car down and wouldn't let it starts because "he thinks there's no oil"!
So now I'm looking for $450 for get that job done at dealer. I can do that at home but after that I need to reset codes with professional tools (not a crap from AutoZone) so it doesn't make sence go back to dealer and pay $118 more for reseting. Let them work... I'm f***ing tired of this repairs...
Wow the dealer took you for a ride, the oil level sensor will not stop your car from running. most likely is was the faults from when your replaced the cam sensors (which will stop your car from running) and yes your autozone scan tool will delete the oil level sensors out of the dme.
generic scans tool just scan dme (and maybe the egs no sure) so any faults in the dme can be deleted
 

·
Registered
Joined
·
6 Posts
Hello! First time poster here. My '02 330i ran just fine for me tonight, stopped at the house for 20 mins, and then refused to start. Or at least, it starts, has a bad idle, and then shuts off. I'm not sure if it's related to the oil sensor or not, but I'm looking for any help I can get.
 

·
ROLL TIDE!
Joined
·
23,914 Posts
Hello! First time poster here. My '02 330i ran just fine for me tonight, stopped at the house for 20 mins, and then refused to start. Or at least, it starts, has a bad idle, and then shuts off. I'm not sure if it's related to the oil sensor or not, but I'm looking for any help I can get.
I already answered your issue in your thread. It is NOT the oil level sensor. BTW, it CAN'T keep your car from starting.
 

·
Registered
Joined
·
2 Posts
Hi I have a 02 745li the fuel pump does work but does not power on when trying to start the car. Do you think I have the same problem?
 

·
Registered
Joined
·
2 Posts
hey thanks 4 getting bak at me. n ur damn right they bul****ted u! lol i changed the oil level sensor and still no joy. very simple to change myself. oil light stopped flashing n that was the only good thing about it. so then i thought f*@k it and decided to strip off all the panels and follow the fuel pump live wire. it went straight into my alarm unit. i disconnected it from there and connected them together. tried starting it and it fired up straight away :). so basically it was just my immobiliser which had played up and it cost me nothing but time to fix it. soo glad i didnt pass it on to main dealer, god knows what they wouldve charged me for.
Once up n running with all the plastics n wiring back in place it was time for a cruise in the sun with the roof down.... but guess what... my bloody roof stopped working now!!! grrr lol. i am now just driving it and am not looking forward to having a go to fix the roof! lol the joys of motoring eyy
yours had just run outa fuel? lol goes to show these highly paid bmw technicians are a load of bollox. we done better ourselves
I have a 02 745li the fuel pump was tested and works but when trying to start the car it will not start or power the fuel pump. Do you think this will solve my problem?
 

·
Keeping it surreal
Joined
·
43,184 Posts
I have a 02 745li the fuel pump was tested and works but when trying to start the car it will not start or power the fuel pump. Do you think this will solve my problem?
You`re posting in the wrong Forum....take this question over to the proper (E65) Forum. Start a new thread, stating the nature of your problem in the thread`s title.
 
1 - 13 of 13 Posts
Top