BimmerFest BMW Forum banner
1 - 20 of 27 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
wipers just stopped working out of no where one day...:dunno:
anything i can check before replacing motor? im sure there are some fuses or relays that could be bad ? anyone have similar problems or anyone have any info on replacing the windsheild wiper motor? thanks for any input

its an 06 e90 sedan
 

·
Registered
Joined
·
301 Posts
did you check the fuse?
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #4 ·
dont have manual...anyone know what fuse or relay controlls this? would like to try and swap relays before motor..
 

·
Registered
Joined
·
650 Posts
Driving without operational windshield wipes sounds dangerous to me. If you can't fix it quickly take it in and consider the price a bargain.

On the other hand, if the car is not being driven and you have time I would first check to see if 12VDC is at the wiper motor connector. If not then the problem is in the relay/fuse. If there is voltage at the connector, the wiper motor or park switch are suspect. You shouldn't need a circuit diagram to make this test. Finally, if the fuse, relay and motor are all OK then the problem is in the wiring harness in which case you are better off just running a new wire instead of trying to find the break.

I'm sure that once you start the debugging process you will find the problem.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #6 ·
its my girls car..it doesnt get a ton of miles but wanna get it squared away without just dropping off at stealership or some jobo mechanic...i have a hard time doing that unless it something major..i get employee cost on parts @ dealer but dont know any bimmer experts per say..im handy with most diy stuff on later model euros but no expert..

also the wiper fluid still works and shoots out....dont know if that means anything...???

i have a good meter..am i checking the VDC with key in or car running or anything or just car totally off??
-by wiper motor connector...you mean the plug on motor?...like pull the plug and test the end or hold meter to plug wile still pluged into motor?
-what is park switch? the acutal stalk that you use to turn on wipers?

thanks for help !
 

·
Registered
Joined
·
650 Posts
Yes, unplug the motor and test at the wire connector for 12 VDC when the car ignition is on and the wiper switch is asking for the wipers to work.

After this test take it in to be fixed. You will know if it is a wiper motor problem and hence the approximate cost of repair to avoid being ripped off.

My thoughts for your consideration.
 

·
Registered
Joined
·
19 Posts
My wipers konked out too!

My wipers just totally stopped working on my E90 sedan - also just out of warranty! In the fuse box in the glove compartment the little card seems to say that the blue relay on the left operates the front wipers. I pulled out the relay and the part number (61366918816 - relay) is apparently discontinues (according to getBMWparts.com). So no I don't know what to do! I can't seem to find that part anywhere on the internet. The local dealers say that it is special order.

I suppose I'll put the relay back in and check the leads to the wiper motor as suggested. Then take a meter to it.

Thanks for any help!!
 

·
Bimmerdex 7.4!
Joined
·
11,163 Posts
its my girls car..it doesnt get a ton of miles but wanna get it squared away without just dropping off at stealership or some jobo mechanic...i have a hard time doing that unless it something major..i get employee cost on parts @ dealer but dont know any bimmer experts per say..im handy with most diy stuff on later model euros but no expert..

also the wiper fluid still works and shoots out....dont know if that means anything...???

i have a good meter..am i checking the VDC with key in or car running or anything or just car totally off??
-by wiper motor connector...you mean the plug on motor?...like pull the plug and test the end or hold meter to plug wile still pluged into motor?
-what is park switch? the acutal stalk that you use to turn on wipers?

thanks for help !
I'd help you. I have every wiring diagram for your car from front to back. I have years of experience repairing wiper problems. I have access to BMW online repair sites, and belong to the International Automotive Techicians Network, a resource group which probably has a dozen postings of problems and fixes which apply to you.
Unfortunately I may be a "jobo mechanic" and could screw up your car, so forget it. You shouldn't prejudge people based on their hand color 'tturbonegro'.
 

·
Registered
Joined
·
19 Posts
wiper relay replacement part number

I found out that the replacement relay part number for the wiper is: 61316919113, according to Evan at getBMWparts.com. They are shipping it out today. Evan has been very helpful, by the way, in helping to track down the part and ship it quickly.

DSXMachina - I was unaware of the apparently derogatory reference by the original poster. I'm sorry that you were offended and hope you don't hold it against the rest of us that might have a similar wiper problem.
 

·
Registered
Joined
·
189 Posts
Try some RainX on your windshield. I use it and rarely have to use my wipers. It could be a temporary solution until you get your wipers fixed if rain is in the forecast. The only problem I have found is it tends to dissolve your wiper blades when you do have to use them and shorten their life.
 

·
Registered
Joined
·
19 Posts
Wiper problem - Fixed

By the way, it was the relay that was faulty. I replaced it with part 61366918816 and the wipers work fine now. I got the part from getBMWparts.com

Thanks!
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #19 ·
I'd help you. I have every wiring diagram for your car from front to back. I have years of experience repairing wiper problems. I have access to BMW online repair sites, and belong to the International Automotive Techicians Network, a resource group which probably has a dozen postings of problems and fixes which apply to you.
Unfortunately I may be a "jobo mechanic" and could screw up your car, so forget it. You shouldn't prejudge people based on their hand color 'tturbonegro'.
woooahh..u took that way wrong man...by jobo mechanic i was referring to all the unreliable local guys around me...its very hard to find a good mechanic that has knowledge AND reliability...thats why i go online or diy or watever anything i can...everyting else i take to friends who have their own small side shop who are into euros or who work at dealership during the day, etc..
i have many years and thousands of posts on many other euro sites.. i come on for people like you that are usually willing to help...most jobo mechanics around me would know what a forum was if their kid was the admin....let alone how to use one for help...
didnt mean to offend anyone

...

i unplugged the motor and i am getting constant power (12v) when i put the meter to the plug...so im gonna say that this means the blue relay in glove box is working ok and power is being sent but the motor is not responding...correct ?? i also tried the ol fashion give it a few taps with the wrench...still not working.... pretty sure i need a motor, correct ??
any info on replacing one or where anyone got one beside the dealer?
looks pretty basic...couple of bolts, little wiggling in and out..but also seems really tight in there..

thanks for ANY info, help, or suggestions....
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #20 ·
BUMP... i replaced complete motor and assembly (new from BMW) and they are still not working... what else could it be..?? the stalk that turns on/off wipers still works for the wahser fluid and auto button on it lights up...is there a module that controlls this somehwere ..??
 
1 - 20 of 27 Posts
Top