BimmerFest BMW Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all
I am new to this forum.
I have a 520i from 2001 and i have a problem with the wipers.
I was driving home from in rainy weather an dthe wipers just stopped.
I've allready cheked the fuse and it was ok.
Dont know where to look next.
Can anyone help me ?

Thomas
 

·
Uh.. Did you say "yuuts"?
Joined
·
160 Posts
Welcome to the wide world of BMW fixers! Probably should include info on the year and mileage of your car. It generally helps get accurate info. Also lots of people will tell you to search this forum because it has been covered in the past... but I know you just want an answer so....

Odds are you have a bad wiper relay. I had one go out on me last year. The problem was identical to yours. Took about 20 minutes to fix and didn't even get my hands dirty. One of these is what you need:

http://www.autohausaz.com/pn/61368384505

Here's a good write up on the repair. Simple and straight forward.

http://www.bimmerforums.com/forum/showthread.php?1953667-Windshield-Wiper-Relay-replacement-DIY
 

·
Registered
Joined
·
6 Posts
Hi there "yuuts". I'm ivoryscoast, hope to make contact w/you soon, and that you can help me out. I have a beautiful 1997 z3 I-4, and every once in a while she develops a small problem that help is required with. The windscreen wipers are the culprit this time. Whilst tooling along one rainy day, I realized that only hi speed was working. At the same time I saw that the driver wiper was over reaching the driver windscreen post. When I turned the wipers off, they stopped mid windscreen. Since I've discovered that lo spd only works intermittently as well as the actual intermittent setting. I've read a load of posts from all over the spectrum and found one gentleman named Roger helping "Mike 1997" out and went into wiring specs & testing in pretty much a great deal. Personally, I believe that the problem would be somewhat simpler, like for instance a relay or similar thing. I've also seen posts where you're supposed to remove the glove box because a relay is located right behind it. Looked into that, looks like I've gotta take out the whole right side of the dash. So this leaves me in this predicament, I am lothe to go on a fishing expedition, and I detest the thought of throwing parts at it. Accuracy is the goal here, I want to live long enough to have fun with my toy, not spend time with her stuck in my garage! Can you help me out? Any & all suggestions would be greatly appreciated. Also, sorry for such a lengthy post. Ivoryscoast.
 

·
Just call me 777.
Joined
·
852 Posts
Hi there "yuuts". I'm ivoryscoast, hope to make contact w/you soon, and that you can help me out. I have a beautiful 1997 z3 I-4, and every once in a while she develops a small problem that help is required with. The windscreen wipers are the culprit this time. Whilst tooling along one rainy day, I realized that only hi speed was working. At the same time I saw that the driver wiper was over reaching the driver windscreen post. When I turned the wipers off, they stopped mid windscreen. Since I've discovered that lo spd only works intermittently as well as the actual intermittent setting. I've read a load of posts from all over the spectrum and found one gentleman named Roger helping "Mike 1997" out and went into wiring specs & testing in pretty much a great deal. Personally, I believe that the problem would be somewhat simpler, like for instance a relay or similar thing. I've also seen posts where you're supposed to remove the glove box because a relay is located right behind it. Looked into that, looks like I've gotta take out the whole right side of the dash. So this leaves me in this predicament, I am lothe to go on a fishing expedition, and I detest the thought of throwing parts at it. Accuracy is the goal here, I want to live long enough to have fun with my toy, not spend time with her stuck in my garage! Can you help me out? Any & all suggestions would be greatly appreciated. Also, sorry for such a lengthy post. Ivoryscoast.
This is the kind of thing that goes in a PM, or in the E36 for as they are that platform not this one.
 

·
Uh.. Did you say "yuuts"?
Joined
·
160 Posts
Honestly I have no idea how to repair an e36. Only BMW I feel at least somewhat qualified to work on is my e39. If you lived nearby we could tinker with it, but I see you're in Florida. Kind of a long distance for wiper repair.

Try these folks over here:
http://www.bimmerfest.com/forums/forumdisplay.php?f=7

They ought to be able to assist.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top