BimmerFest BMW Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Any one else havig an issue with there front indicators and wipers? Here and there the right front indicator blinks as if faulty. I change the bulb but still once in a while i get this problem. also the windshield wipers will not wipe in any higher setting then the normal. Suggestions(fuses or new motor or wiring)? driving a 325i 89.
 

·
Needs more cowbell
Joined
·
4,516 Posts
bodiger said:
Any one else havig an issue with there front indicators and wipers? Here and there the right front indicator blinks as if faulty. I change the bulb but still once in a while i get this problem. also the windshield wipers will not wipe in any higher setting then the normal. Suggestions(fuses or new motor or wiring)? driving a 325i 89.
My '89 325is has the blinker problem. The fault lies in the connector at the back of the turn signal light in the bumper. The prongs in the housing have corroded away, and the plug-side mate to that doesn't look any better.

I have the replacement, but removing the indicator housing is a PITA.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #6 ·
:( Think the motor might be going. The wipers are fine and the switch clicks correctly. Thx for the info.
 

·
On Top
Joined
·
8,772 Posts
i had a very similar prob w/my 89 325i one day driving home from work it was barely raining and my wipers started "stuttering" on medium speed put on high worked fine ........for 15 more minutes:banghead:
 

·
Banned
Joined
·
0 Posts
`E30 wipers suck. Ive replaced the linkage several times. The Intermittent switch twice. And reaching the wiper components through the openings in the body BMW left is a major pain. Literally, it hurts. Oh, well the price you pay for driving a classic (or soon to be).

I love RainX.
 
1 - 10 of 10 Posts
Top