BimmerFest BMW Forum banner

1 - 20 of 59 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter · #1 ·
I got my car back from the body shop today :D They did a great job! Here's my problem; They disconnected the battery, and I didn't have the code for the radio. After I picked up my car, the radio display said CODE ----- I went to the BMW dealership and the service tech didn't really know what he was doing (perplexed look on his face, tried to uninstall the radio to get the SN etc etc) I brought up the SN on the radio's display and he took that into the computer. He came back with a 5 digit code and proceded to enter it. The radio did not activate, rather it asked for the code again. He entered it again.... and one more time (a total of 3 attempts). Now the display reads CODE WAIT. He told me that it was supposed to do that and that the radio would come on in 90 minutes. I don't believe him. I do computer security, and when someone enters their password incorrectly 3 times in a row, the computer locks them out for a preset period of time. I think that's what is going on with my radio right now.

Can anyone help me? Is the service writer correct? Will my radio come back on by itself? What is the proper sequence for entering the code (assuming that I have the correct code).

Thanks!!!
 

·
Crazy Canadian
Joined
·
1,095 Posts
SoCalZ3 said:
Can anyone help me? Is the service writer correct? Will my radio come back on by itself? What is the proper sequence for entering the code (assuming that I have the correct code).

Thanks!!!
You have to leave the car in the 'ON' position where the accessories are on with the radio on displaying CODE WAIT for 90minutes. It will then reset to CODE ----- where you can enter the code.

If the code he gave you doesn't work, get them to look it up again. There are two makers of the radios in these cars, alpine and blaupunkt. The codes for each are different. Chances are they gave you the code for the wrong make.

I went through this when I first bought my car.
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #3 ·
Thanks for the fast reply.

This brings up one more Q... If the code that was entered is correct, can I be driving the car for the next 90 minutes, or do I have to leave it parked in the ON position?

I'm trying to leave for a trip and really want to get on the road. :D
 

·
Registered
Joined
·
2,221 Posts
SoCalZ3 said:
This brings up one more Q... If the code that was entered is correct, can I be driving the car for the next 90 minutes, or do I have to leave it parked in the ON position?

I'm trying to leave for a trip and really want to get on the road. :D
If the code that was entered was correct, the radio would work. Sounds like you have the wrong code. I assume you're not the original owner. You can try looking in the owner's manual. The original owner may have stored the card with the radio code there.
 

·
Crazy Canadian
Joined
·
1,095 Posts
SoCalZ3 said:
This brings up one more Q... If the code that was entered is correct, can I be driving the car for the next 90 minutes, or do I have to leave it parked in the ON position?

I'm trying to leave for a trip and really want to get on the road. :D
After entering the code wrong 3 times it goes into the CODE WAIT mode and locks you out from entering. You have to leave the car on for 90minutes, it doesn't matter if it's parked or driving, just as long as the radio has power. when it gets to CODE ----- enter it again. If the code is right, it will work on the first try... if not.... i repeat:

If the code he gave you doesn't work, get them to look it up again. There are two makers of the radios in these cars, alpine and blaupunkt. The codes for each are different. Chances are they gave you the code for the wrong make.
because this is what caused tons of hassle for me when I got the radio code
 

·
///M Practical
Joined
·
859 Posts
bol said:
If the code he gave you doesn't work, get them to look it up again. There are two makers of the radios in these cars, alpine and blaupunkt. The codes for each are different. Chances are they gave you the code for the wrong make.
Yes, as bol indicated, the same serial number can come up on both brands with different security codes.
 

·
Registered
Joined
·
113 Posts
Discussion Starter · #7 ·
BOL & The Other Tom - Thanks for the answers!

I missed your posts, because I had to get on the road Friday afternoon. Reading them now, you are perfectly correct. The code that I got (BTW, I'm the 3rd owner and the manuals got lost along the way) was incorrect. I ended up driving 6 hours without any tunes :mad: Saturday morning I called another BMW dealership and was helped immensely by the tech, over the phone. I explained what had happened, and that I had a code for an Alpine radio that didn't work. He said he'd get me any other codes that might work with the SN from the radio. He said that the only other brand available on my car would be a Blaupunt, and gave me the code for that. Once entered, wait about 5 nervous seconds and VOILA!!! Sweet music was filling the car. I had no idea there were 2 different brands of radio, and what really strikes me as strange, is that they share serial numbers. One would think that the serial number would be brand specific. :dunno:

I really can't thank you guys enough. Once again this board has come thru with the correct and timely information.

THANKS AGAIN FOR THE GREAT ANSWERS. I owe this board and will continue to monitor it answering any questions that I can.
 

·
Registered
Joined
·
4 Posts
Can you pliz lead me to the guyz who gave you the code coz i have the same problem only that mine is locked completely and i cant even drive my car.
 

·
Registered
Joined
·
32 Posts
I had the same issue at my local dealer. The radio code retrieved from the computer was incorrect even though it had my correct serial number. He had to talk with bmwna to get the correct code. The funny thing was he had two additional codes to try. I was happy when one was right.
 

·
Registered
Joined
·
1 Posts
I getting the same issues with y radio I would like to find out if you can send the two codes so I can try boh one of them should work!

Thanks
 

·
Registered
Joined
·
3 Posts
Well I had a DEAD DEAD battery that wouldn't even take a jump charge so towed to get a new one. The STEALER I mean dealer obtained the (WRONG) code and entered it several times until it went to lockout CODE WAIT.

I drove home and found the pass code card and it's a completely different number (number they assured me WAS the right number does not match US or EUROPE). Must be another brand for same serial as mentioned above?

Interesting in that I bought the car from THIS stealer/dealer.

So if I just turn on the key to FIRST position (not second) for an hour or two will it clear back to CODE _ _ _ _ _ or did their THREE attempts lock me out for good.

3) I do NOT have a charger so setting key to SECOND position worries me...too much drain on barely used/charged new battery. I drove for over an hour and the CODE WAIT did NOT clear. So now trying the first position parked.


Maybe I need to start a new thread?
 

·
Warning - Thin Air
Joined
·
1,793 Posts
It just needs to be in a position where the radio is on. Then wait about an hour and it should display the dashes where you can enter your code.
 

·
Registered
Joined
·
12 Posts
radio code

(you all must be tired of this stuff) but,
I have read ALL your posts re-radio code...I have my serial number and code...I have verified ALL numbers with my dealer and 2 others AND BMW of North America...after replacing battery...I have plugged in the numbers 7 times and still get code wait... I have again asked all dealers if this is FOR SURE an Alpine...not the other makers and they ALL say it is alpine and these numbers are correct and don't show for other radio manufacturers...I have No Radio, Kidsl...and no answers and no sounds...what's next??? any ideas???
thanks,
Mumbles1
 

·
///M Practical
Joined
·
859 Posts
First, I would contact BradK over on the Z3 forum on bimmerfest. He may be able to retrieve it for you. Next, I would pull the radio. It should indicate on the back exactly who manufactured it.
 

·
Registered
Joined
·
12 Posts
Thanks I will check it out but...my point is: who the manufacturer is has been determined...the dealerships ALL have said it can only be Alpine because the serial number works only with Alpine and none other....!EVERYTHING WORKS OUT....BUT THE RADIO...Capice?
 
1 - 20 of 59 Posts
Top