BimmerFest BMW Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hey guys,

I am new to the forum, but not new to working on cars, or even to working on my Z3. I've been confused by a problem, and I am turning to you!

I have a 1998 Z3 2.8 5-speed with 93k. Recently, I've developed this rapid "wobbling" or "thudding" noise that comes on as quickly as it disappears when launching from 1st or 2nd. The problem only appears when I am on the gas all the way, and from 1st or 2nd. It does not appear when the car is any higher gears. Additionally, it occurs in the lower RPM band, say around 1.5-3.5k. This is not my first BMW, so I assumed it might be my center support bearing or guibo, since the noise seemed to be centered from where the noise was coming from.

Well, I got underneath the car and replaced both the center support bearing and the guibo. It has not fixed the problem at all. I've been trying to pay attention to where the noise is coming from, and it seems to be coming from the center of the car under my center console.

I used all OEM/BMW parts, and I marked the driveshaft before I removed it to make sure it went back in the same way. I am fairly certain I aligned the driveshaft correctly. What haven't I thought about? Has anyone else had this problem?

My initial thought was that I didn't preload the center bearing enough, but I before I go back underneath the car, I wanted some other opinions. Can anyone shed some light here? Thanks!
 

·
Registered
Joined
·
1,578 Posts
How did the trans mounts look ?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
They didn't look too bad, but I am not really sure how hey are supposed to look. I didn't see any signs of cracking or brokenness. Are they a good thing to preventatively replace?
 
1 - 3 of 3 Posts
Top